This project is read-only.

Error on Fresh load of 1.8 on a DNN 5.1.2

Sep 30, 2009 at 1:31 AM
Edited Sep 30, 2009 at 1:33 AM

New install of DNN 5.1.2 - no install errors,

Made a new Portal, uploaded the tss_DKP 0.1.8 module definition,  no errors

added module to home page ContentPane, and I get:

"A critical error has occurred.
Object reference not set to an instance of an object."

Tried to adjust "settings" on module, but the only non-DNN settings offered is one single box for :

Board Name:

 

 

[drop down box, that is blank]

but there is nothing in the drop down, and it wont let me ADD anything in the box either.

 

 there are no other 'settings' to set.

Oct 2, 2009 at 2:23 AM

Provide a link to your site if you can. I'd like to see the critical error.

In regards to the Board setting, you have to first make a boad in the module itself. Once a board is made, you can attach a module instance to it for display using the setting you're looking at.

The demo site I'm running is a clean DNN 5.1.2 install, and everything is working as expected.

Oct 2, 2009 at 5:09 PM
Salaza wrote:

Provide a link to your site if you can. I'd like to see the critical error.

 

http://67.180.53.132/wowsaintjohn I set up the DKP page to now be public view.

Oct 3, 2009 at 4:54 PM

So your error message is...

The virtual path '/DesktopModules/tss_DKP/tss_ucBoards.ascx' maps to another application, which is not allowed.

Something is unusual about your site, which is not allowed. I would check the installation of your DKP module. Confirm that it installed correctly to your hoster, and that you aren't doing something crazy like trying to map a virtual directory from this portal install to the directory of another portal install. It's simply not allowed.

Oct 5, 2009 at 7:13 PM

Well, I do no beleive I did anything odd...

Installed tss_dkp, added it to a new page.

Just to check, I uninstalled, and re-installed the module, and build a new page...

Still get the same issues... the error mentioned above and when I go into 'settings' for the module, I see a Board Name drop down box, that is completely empty, with no way to ADD an entry to it.

 

Oct 5, 2009 at 11:21 PM

Even when the module is behaving as expected, you won't be able to add a board there.

Boards are added un the "Board" panel that's in the same list as the "Players", "Raids", etc.

That drop down box is merely where you associate an instance of the module with the Board that it should display.

Unfortunately, I think this is an issue with your particular install of DNN. You might want to check out the forms or try using an earlier version of DNN. The only way you could be getting this issue is if you've installed the module to a directory that's outside of the virtual directory of your DNN install.

Oct 9, 2009 at 6:16 PM

I would like to uninstall DKP intirely, in order to try again, but it seems that the SQL uninstall is.. well..  blank.

Do you have a sql script that will clean out my DNN database properly, to enable the next Install to run cleanly?

Oct 9, 2009 at 6:51 PM

As long as you aren't using any object qualifer values, all the tables  and the store procedures will start with "tss_"

I just manually delete them from the database when I do a cleaning.

The uninstall script is empty because most people don't really plan on dropping everything when they remove the module... or rather, I should say, there were quite a few angry people who accidentially deleted their DKP systes as a result of unisntalling the module... so we left it blank.

Oct 9, 2009 at 8:33 PM

Thank you for the info.. I cleared the DB of all TSS_ tables and SP, etc... and reinstalled ...

I still get the orginal error. I even tried to place the Module on a totally unrelater portal, just to see if something else was amiss.  Same error.

I will try again once 1.9 is out. :)  (it is not like my guild is NEEDING a RAID DKP system yet, we a still leveling.)

Oct 10, 2009 at 3:28 AM

Are you running your own IIS? I suspect its something there.

Oct 22, 2009 at 7:12 PM

Running Windows 2008, IIS.  I didn't (knowingly) change anything from the defaults. ... any hints?

Oct 24, 2009 at 5:57 PM

Unfortunately without more information about your IIS configuration, I have no hints for you.